I hate algae ... !!

Forum for discuss on algae.
jack
Moderator
Moderator
Posts: 2562
Joined: Mon Oct 17, 2011 4:28 pm
Location: Ahmedabad

I hate algae ... !!

Unread postby jack » Thu Apr 27, 2017 4:40 pm

Hello everyone

I have BGA in my tank ... rather it looks like BGA to me and when i say i hate algae means i literally hate algae

Attached are the pics of algae in the tank

Basic info of the tank

Tank is been running more than a year with no mortality in discus.
6X2X2 main display with wood and some ferns and anubias
5X2x2 sump with 12 nos of marine pure blocks
1 fluval fx5
2 filter socks on overflow
I always like over filteration and less stocking so fishes health is not compromised
Have 16 discus, 6 whiptails, 3 bristlenose

Tank is situated outside in compound where it gets ambient light
No direct sunlight
Light in the tank is for 2 hours 6:30 to 8:30 pm just simple led 4 foot tube and plants have decent growth
No fert dosing since 6 months
Only ro water change
Once a week around 20%
Tds is 82
Nitrate, nitrite, amonia all 0 not trackable

Every week i syphon this algae and still within 2-3 days it bounces back. This problem i am facing since 2 months now.

Thank you

Image
Image
Image
Image


Sent from my iPhone using Tapatalk


Finally i am Broke but Happy :D

User avatar
aquascapist
Rising Star of AquaPetZ!
Rising Star of AquaPetZ!
Posts: 328
Joined: Mon Jan 14, 2013 12:27 pm
Location: New Delhi

Re: I hate algae ... !!

Unread postby aquascapist » Thu May 04, 2017 10:54 am

looking at the mats it certainly looks like bga...imho it looks to be thriving because of the sunlight...looking at its needs all it needs is phosphates to thrive. Im purely coming to this conclusion from a saltwater perspective cause here we have the red slime algae which is its distant cousin (cyanobacteria). Can you keep some invertebrate which will stir the sand?
Warm Regards,
Aditya

jack
Moderator
Moderator
Posts: 2562
Joined: Mon Oct 17, 2011 4:28 pm
Location: Ahmedabad

Re: I hate algae ... !!

Unread postby jack » Thu May 04, 2017 10:57 am

The problem was
1) there was carbon running in the filter
2) sump dust which was accumulated

have cleaned everything and removed the carbon.
We can keep Corys to keep the sand areated but corys dont live long in my tank so dont want to take chances...

Thank You
Finally i am Broke but Happy :D